Dolphin, the GameCube and Wii emulator - Forums

Full Version: PERFECT SETTINGS FOR SONIC COLORS 720P
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Come on guys. im really happy i could help you all but dont be mad at the guy who posted the other settings. it obviously worked for him, no need to fight lol. if it doesnt work for you, then just use the settings i said to use. no need to fight, were all brothers and sisters here Smile. now go enjoy sonic colors already Big Grin
SolarSonic's settings and my findings / settings for best performance are *both* correct.

Enabling 'Accurate VBeam Emulation' *does* give a significant boost to the emulation speed (up to 20%) on any CPU regardless of speed or model, but there's an issue with Dolphin's framelimiter when this setting is enabled, which results in massive slowdown (>30%).

You will experience major slowdown if you set the framelimiter to 'Auto' and enable the Accurate VBeam option

For example, the framerate at the very beginning of Level 1-1 drops from 30 to 20.

The buggy framelimiter also cuts the framerate in half in the Tropical Resort Map (from 60fps to 30fps) for some odd reason. Only this map is affected (all other maps run at 60fps).

Disable the framelimiter and the slowdown is gone, but the game runs way too fast to be playable Smile

If you enable 'Limit to fps' , everything runs at 60fps (double speed gameplay, still way too fast)

Manual limiting to [30fps] gets you a black screen after the SEGA logo (see previous post for more info [updated])

[35fps] works, but it's still faster than the real thing.

For a consistent framerate of 30fps , the only option is to leave VBeam at the default setting, so you can enable the framelimiter without experiencing slowdowns.

[EDIT] Updated the previous two posts with the new findings.

eljuggy Wrote:I've got a AMD Phenom II X4 955 clocked at 3.8ghz and a 4850 HD and vbeam was my friend !

Same CPU, but at 3.5GHz
30fps @ 4x internal res (no SSAA) with VBeam OFF, Block Merging ON and framelimiter on 'Auto' (r7669 using the DirectX 11 renderer)
set your external frame buffer to virtual, dont disable it and you wont get the slowdown your talking about
Ok so we've established it works for some people and not for others, great. I tried your initial settings and they slowed my game down. I don't know if you've since changed your settings but I'm still using the posted ones in the opening post at 30fps with 3x internal and 4xssaa.
lol hot damn. i didnt think this thread would still be on the first page of the forums.
!!thank you so much
you are the best
(07-26-2011 09:02 AM)Solarsonic Wrote: [ -> ]lol hot damn. i didnt think this thread would still be on the first page of the forums.

Btw have you got "perfect settings" for other games? Big Grin
(07-27-2011 08:15 PM)LordVador Wrote: [ -> ]
(07-26-2011 09:02 AM)Solarsonic Wrote: [ -> ]lol hot damn. i didnt think this thread would still be on the first page of the forums.

Btw have you got "perfect settings" for other games? Big Grin

yeah like Super mario galaxy 2..
ive never even played super mario galaxy 2 before so no perfect settings for that xD
(07-20-2011 12:24 AM)Solarsonic Wrote: [ -> ]here is the video with the specs in the description.
http://www.youtube.com/watch?v=bdzTrkPt8LA
add some views people Big Grin xD

for dolphin 3.0:
use direct3d9
internal resolution 2x
skip efb access to cpu
EFB copies to TEXTURE not ram
ignore format changes
Disable frame buffer
texture cache second from the right
Fast mipmaps
Disable per pixel depth
Open MP texture decoder.

Config:
lock threads to cores,
enable dual core
enable idle skipping

If you are using the revision 7669 for the internal resolution upgrades like me then use the same settings EXCEPT use opengl instead of direct 3d9.

VERY IMPORTANT SETTING: right click sonic colors and click properties. then put a check mark on accurate VBeam emulation. THIS IS VERY IMPORTANT.

I will be posting more vids on how well laptops can run games of dolphin so stay tuned xD


I have a problem. When I start the game ( and this happens with just Sonic Colors ) it starts with the Sega Logo but after the Sega logo it freezes and it dosen't advance. I have Dolphin r7714M x86
(07-25-2011 03:50 PM)kirbypuff Wrote: [ -> ]SolarSonic's settings and my findings / settings for best performance are *both* correct.

Enabling 'Accurate VBeam Emulation' *does* give a significant boost to the emulation speed (up to 20%) on any CPU regardless of speed or model, but there's an issue with Dolphin's framelimiter when this setting is enabled, which results in massive slowdown (>30%).

You will experience major slowdown if you set the framelimiter to 'Auto' and enable the Accurate VBeam option

For example, the framerate at the very beginning of Level 1-1 drops from 30 to 20.

The buggy framelimiter also cuts the framerate in half in the Tropical Resort Map (from 60fps to 30fps) for some odd reason. Only this map is affected (all other maps run at 60fps).

Disable the framelimiter and the slowdown is gone, but the game runs way too fast to be playable Smile

If you enable 'Limit to fps' , everything runs at 60fps (double speed gameplay, still way too fast)

Manual limiting to [30fps] gets you a black screen after the SEGA logo (see previous post for more info [updated])

[35fps] works, but it's still faster than the real thing.

For a consistent framerate of 30fps , the only option is to leave VBeam at the default setting, so you can enable the framelimiter without experiencing slowdowns.

[EDIT] Updated the previous two posts with the new findings.

eljuggy Wrote:I've got a AMD Phenom II X4 955 clocked at 3.8ghz and a 4850 HD and vbeam was my friend !

Same CPU, but at 3.5GHz
30fps @ 4x internal res (no SSAA) with VBeam OFF, Block Merging ON and framelimiter on 'Auto' (r7669 using the DirectX 11 renderer)

I still get black screen after SEGA logo
(07-24-2011 08:31 AM)kirbypuff Wrote: [ -> ]@ExtremeDude2:

- Sonic Colors won't boot on slower PCs regardless of the VBeam setting. The game requires a CPU that can sustain a framerate of more than 30 fps at the SEGA logo. Drop down to 30 fps and you will get a black screen.

This game is extremely picky (unlike 99.9% of the GC and Wii games that work without problems even on a CPU underclocked to 800MHz)

Quote:GTFO
WTF?

Enabling 'Accurate VBeam emulation' does speed up Sonic Heroes (up to 20%).
But with the framelimiter set to 'Auto', this option has the OPPOSITE EFFECT. It speeds up the menus and the less demanding / simple stuff, but the more complex scenes (gameplay) get a major slowdown.
Try the very first level (Tropical Resort Zone Level 1-1), for example with 3x EFB scale and no SSAA and observe the FPS.

Solid 30fps with Accurate VBeam disabled, only 20fps with the option enabled (but the title screen finally reaches full 60fps - LOL).

The VBeam setting is like a double-edged sword Smile

Enabling 'Block Merging' helps a lot in this first zone (3~4 fps boost)

Quote:What?
- If you're using an older revision of Dolphin (e.g. r6515) for Sonic Colors, you should avoid the OpenGL renderer like the plague. Older builds have lots of issues with OpenGL, but no issues with D3D9/11.
- On Windows, the Direct3D renderers are more efficient (especially with ATI/AMD GPUs)

lol srry guys for putting so many questions about this but I'm new here and just got this today

So um what happens to me I have r7714 ( and don't feel like downloading r6515 DX ) my CPU is Duo T6570 and my VGA is nVIDIA GeForce GT 320M; VRAM : 1 GB
On Dolphin 2.0 the game did work pretty good but I had to change the Dolphin since that one didn't have Gecko Codes
Pages: 1 2 3 4
Reference URL's