Dolphin, the GameCube and Wii emulator - Forums

Full Version: Cursor stays in the center of the screen problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

velhart

I was playing Tales of Symphonia: Dawn of the New World and i noticed one annoying thing: the cursor stays in the middle of the screen during gameplay. the hide button doesnt help becoz it doesnt hide it permanently.

tried moving the cursor and it goes back in the middle of the screen...

does anyone know how to go about with this problem?

thx in advance...
Use the default controls for a mouse controller IR pointer. (click the "Default" button)
(10-25-2010 01:46 PM)velhart Wrote: [ -> ]I was playing Tales of Symphonia: Dawn of the New World and i noticed one annoying thing: the cursor stays in the middle of the screen during gameplay. the hide button doesnt help becoz it doesnt hide it permanently.

tried moving the cursor and it goes back in the middle of the screen...

does anyone know how to go about with this problem?

thx in advance...

The hide button works better when you mantain the button pressed Tongue . You should map the cursor to the mouse. By doing that, you can move the mouse pointer to wherever you want in the screen. Even outside of it if you're running in windowed mode. I hope that helps you. Don't own that game so can't try it for myself. But it seems like the pointer in Mario Galaxy.

velhart

@Billiard : Really sorry for troubling u but could u give me a step-by-step instructions? I'm using the dolphin SVN R 6306. there's no default button for the IR. there's one for the whole wiimote config which basically empties the whole inputs...

@rodialbloalmeida : i did, i tried moving the mouse to the side, but the cursor keeps going back to the center of the screen...
(10-25-2010 08:18 PM)velhart Wrote: [ -> ]@Billiard : Really sorry for troubling u but could u give me a step-by-step instructions? I'm using the dolphin SVN R 6306. there's no default button for the IR. there's one for the whole wiimote config which basically empties the whole inputs...

@rodialbloalmeida : i did, i tried moving the mouse to the side, but the cursor keeps going back to the center of the screen...

Ok. Try this instead: The hide button can be mapped to a non-pressed state. Thanks Billiard26 for that.

[Image: mappinghide.jpg]

The config in the picture means that the pointer will be in a "always hide" state, unless you push and hold the button/key you mapped for Hide command. For example, the B button on your joystick.

In other words:
-> to maintain hide, don't push the B button
-> to not hide (show the pointer), push AND HOLD the B button

I hope that helps you now. I don't have the game, so can't acctualy see the issue you have with it.

velhart

Thx guys! finally fixed it... ^^
Glad to help. Smile

DragonSyn

(10-25-2010 08:59 PM)rodiabloalmeida Wrote: [ -> ]
(10-25-2010 08:18 PM)velhart Wrote: [ -> ]@Billiard : Really sorry for troubling u but could u give me a step-by-step instructions? I'm using the dolphin SVN R 6306. there's no default button for the IR. there's one for the whole wiimote config which basically empties the whole inputs...

@rodialbloalmeida : i did, i tried moving the mouse to the side, but the cursor keeps going back to the center of the screen...

Ok. Try this instead: The hide button can be mapped to a non-pressed state. Thanks Billiard26 for that.

[Image: mappinghide.jpg]

The config in the picture means that the pointer will be in a "always hide" state, unless you push and hold the button/key you mapped for Hide command. For example, the B button on your joystick.

In other words:
-> to maintain hide, don't push the B button
-> to not hide (show the pointer), push AND HOLD the B button

I hope that helps you now. I don't have the game, so can't acctualy see the issue you have with it.


Hello there. I've been searching the forums and the Dolphin config trying to find the settings, but due to the picture being deleted long ago, can't seem to figure it out. Does anyone know what the setting is to have the cursor always be hidden, but appear when pressing the appropriate key mapped to Hide in the WiiMote config? Any help appreciated. Thanks. Smile

Edit: Never mind. I figured it out! Big Grin To anyone that is interested, when mapping a key to the Hide button in the WiiMote config, simply use the NOT operator by right clicking, selecting the key to be mapped and then click Not button. Hope this helps anyone that finds their way here. Also, I apologize for digging this up, but it wouldn't let me post a new thread.
Reference URL's